summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Pfuetzenreuter2022-12-18 19:05:31 +0100
committerGeorg Pfuetzenreuter2022-12-18 19:05:31 +0100
commitd3ba0296dab8bb28bd4624366247c722b58d81b1 (patch)
tree9cab29d80bd8853c587c04715c0ece7dc6bbaefe /setup.py
parentbdc1f1d2b55fe026bebd13905eaaea54d691cb35 (diff)
parent9501cbf678a4ef99ccbd8c53f35b3209569f4c8e (diff)
downloadtakahe-libertacasa-master.tar.gz
takahe-libertacasa-master.tar.bz2
takahe-libertacasa-master.zip
Merge pull request 'Import packaging files' (#2) from libertacasa-package into libertacasa-masterHEADlibertacasa-master
Reviewed-on: https://git.com.de/LibertaCasa/takahe/pulls/2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py66
1 files changed, 66 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..dbf4022
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,66 @@
+#!/usr/bin/env python
+
+import setuptools
+package = 'takahe'
+python_requires = '>=3.10'
+
+requires = []
+test_requirements = []
+
+foundpackages=setuptools.find_packages(where=".")
+prefixedpackages=prefixed=[package + '.' + item for item in foundpackages]
+
+setuptools.setup(
+ name='Takahe',
+ version='300ccfbfac970c25eb73922687ded719750acc90',
+ description='An ActivityPub/Fediverse server',
+ long_description_content_type='text/markdown',
+ author='Takahe Authors',
+ url='https://jointakahe.org/',
+ packages=prefixedpackages,
+ scripts=["manage.py"],
+ package_data={'': ['LICENSE']},
+ package_dir= {
+ 'takahe.activities': './activities',
+ 'takahe.core': './core',
+ 'takahe.mediaproxy': './mediaproxy',
+ 'takahe.stator': './stator',
+ 'takahe.users': './users',
+ 'takahe.takahe': './takahe',
+ 'takahe.api': './api'
+ },
+ include_package_data=True,
+ python_requires=python_requires,
+ install_requires=[
+'bleach~=5.0.1',
+'blurhash-python~=1.1.3',
+'cryptography~=38.0',
+'dj_database_url~=1.0.0',
+'django-cache-url~=3.4.2',
+'django-htmx~=1.13.0',
+'django-storages[google,boto3]~=1.13.1',
+'django~=4.1',
+'email-validator~=1.3.0',
+'gunicorn~=20.1.0',
+'httpx~=0.23',
+'markdown_it_py~=2.1.0',
+'pillow~=9.3.0',
+'psycopg2~=2.9.5',
+'pydantic~=1.10.2',
+'pyld~=2.0.3',
+'pylibmc~=1.6.3',
+'pymemcache~=4.0.0',
+'python-dotenv~=0.21.0',
+'redis~=4.4.0',
+'sentry-sdk~=1.11.0',
+'sphinx~=5.3.0',
+'urlman~=2.0.1',
+'uvicorn~=0.19',
+'whitenoise~=6.2.0'
+],
+ license='BSD-3',
+ zip_safe=False,
+ classifiers=[
+ 'Programming Language :: Python :: 3.10',
+ ],
+)